c++11 gcc4.8.x安装

http://www.ttlsa.com/linux/how-to-install-c11-gcc4-8-x/

要支持c++11特性需要将gcc升级到4.8.x。

配置yum源:

或是直接从这里下载:http://people.centos.org/tru/devtools-2/devtools-2.repo

或安装http://puias.princeton.edu/data/puias/DevToolset/6/x86_64/devtoolset-2-2.1-4.el6.noarch.rpm

安装:

测试gcc版本:

修改环境变量:

发表评论